Frontend/vue

[vue2 - error] Vue packages version mismatch:

SOLYI 2022. 1. 31. 03:04
반응형

온라인에서 다운로드받은 nuxt 프로젝트에서 오류가 발생했다.

npm install > npm run dev 실행했더니 Vue Package version mismatch : 라는 오류가 발생.

 

 

Vue packages version mismatch:

- vue@2.6.14
- vue-server-renderer@2.6.12

 

package.json 파일에서 vue와 vue-server-renderer 의 버전이 명시되어있지 않아서 자동으로 최신 버전으로 업뎃을 했고, 그 결과 vue 와  vue-server-renderer의 버전이 일치하지 않는다는 내용.

 

package.json 파일에 다음을 추가해준다. 

"vue": "^2.6.12",
"vue-server-renderer": "^2.6.12",

 

 

package-lock.json 파일과  node_modules 폴더를 삭제한 뒤 

npm i 를 실행해주면 해결!

반응형
1 2 3 4